• Home
  • Search
    •  
  • Login
    • Username: Password:

      Did you miss your activation email?

Author Topic: Belarus 3 Point Hitch Delay  (Read 4042 times)

Haymaker

  • Global Moderator
  • Full Member
  • *****
  • Posts: 228
  • Country: ca
    • View Profile
Re: Belarus 3 Point Hitch Delay
« Reply #2 on: December 22, 2015, 08:50:05 PM »
Did you take it apart?  If so what did you find?
  • Tractors- '93 Belarus 825 with loader and others...

HorseGuy

  • Newbie
  • *
  • Posts: 1
  • Country: ca
  • new member
    • View Profile
Belarus 3 Point Hitch Delay
« Reply #1 on: November 07, 2015, 04:38:20 PM »
I just discovered this forum and became a member. I have a Belarus 5260 that I have owned for 5-6 years. It has always had a delay between the moment that I move the 3 point hitch lever (beside the seat) and the moment that the arms begin to raise. The delay has always been 1-2 seconds so it was not really significant enough to investigate. Recently the delay has changed from 1-2 seconds to 6-10 seconds (slightly variable) making it pretty difficult to use 3 point hitch mounted implements with any kind of precision. When the arms finally raise they move at normal speeds and have lots of power (I hooked up the heaviest 3 point hitch implement I had and it picked it up no problem). There is an external oil leak in the general area (between the gas tanks) as I can see some accumulation below the cylinder. I have cleaned it up with some degreaser and water pressure and it will slowly accumulate again but I am unable to see exactly where it is coming from as the area is pretty tight to see/access. I figured it would be worth checking to see if anyone could point me in the right direction before I start taking things apart.


Has anyone here ever experienced this and were you able to resolve it?


Thanks!
  • 420 (sold), 800 (sold), 500, 5260, 5490