MTZ Tractor Talk

Main MTZ Talk => MTZ Tractors - Old Models (Belarus) => Topic started by: Bruter on October 07, 2016, 08:29:14 PM

Title: Belarus 420 Does Not Charge Battery
Post by: Bruter on October 07, 2016, 08:29:14 PM
We have a 420 and decided to fix up a few things. When we purchased the 420, it did not charge the battery. It started ok, so we just ran it like that. A few weeks ago, we had the alternator rebuilt and purchased a new voltage regulator, but still no charging. So now I am trying to troubleshoot the charging system but I am having difficulty with the symbols on the alternator.  The symbols are: м, в, Ш and the fourth is three ~ on top of each other. There are two sizes of terminal but only one is larger...в.

Does anyone have an idea what these mean? Thank you!!
Title: Re: Belarus 420 Does Not Charge Battery
Post by: Haymaker on October 12, 2016, 09:37:21 PM
Do you have the operators manual?? It should have a wiring diagram.
Title: Re: Belarus 420 Does Not Charge Battery
Post by: arie515 on October 13, 2016, 10:08:22 PM
We posted free manuals on http://www.mtzequipment.com/tractor-service-manuals
Go to "older models" tab
Title: Re: Belarus 420 Does Not Charge Battery
Post by: Munro5299 on December 03, 2018, 12:19:49 AM
Hello Bruter, Where are you located at? I am Near Edmonton if you are close by you are more than welcome to come have a look at my unit and the charging system as it was just all re wired and still has to have the dash come off for a couple of extras in the next few days, I am running a modified alternator, it is possible that you are running an internal and external regulator in your system and that would be canceling out your charging system but if you are interested feel free to contact me and we can share pictures as I have never seen the original state this unit was supposed to be in.






Chad Munro
780-686-4881
Edmonton Area