• Home
  • Search
    •  
  • Login
    • Username: Password:

      Did you miss your activation email?

Author Topic: Belarus model 560 PTO doesn't engage  (Read 1385 times)

Bamaric

  • Newbie
  • *
  • Posts: 2
  • Country: us
  • new member
    • View Profile
Re: Belarus model 560 PTO doesn't engage
« Reply #3 on: June 04, 2018, 08:53:44 PM »
I did notice at the end of last year it seemed to slip while bushogging but was working until this spring and hasn't worked at all.thats when I replaced the bands.according to my manual this model doesn't have but the 540 rpm.....thanks for your reply
  • Belarus tractor model 560

Haymaker

  • Global Moderator
  • Full Member
  • *****
  • Posts: 228
  • Country: ca
    • View Profile
Re: Belarus model 560 PTO doesn't engage
« Reply #2 on: June 04, 2018, 03:12:01 PM »
What's the history?? Did it work and start slipping ? Is the 540-1000rpm selector engaged?
  • Tractors- '93 Belarus 825 with loader and others...

Bamaric

  • Newbie
  • *
  • Posts: 2
  • Country: us
  • new member
    • View Profile
Belarus model 560 PTO doesn't engage
« Reply #1 on: June 03, 2018, 11:26:06 PM »
Greetings everyone.....I have a model 560 Belarus and the PTO doesn't engage......I have installed new bands and adjusted to specs but still no PTO.Is there anything else I should check?when the lever is in the engage position I can turn the PTO by hand and when I place it in stop position I can't.any help would be appreciated.
  • Belarus tractor model 560