• Home
  • Search
    •  
  • Login
    • Username: Password:

      Did you miss your activation email?

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - DevonB

Pages: [1]
1
Attachments, Loaders and Accessories / Re: Leon 705 loader
« on: December 14, 2017, 10:11:49 AM »
I have a LEON 690? on my tractor, very well built and has a high reach.

2
Member Introductions / Hello from Canada
« on: November 29, 2017, 05:46:54 PM »
Grew up on a beef farm in south central Manitoba.

We had a Belarus dealer near us and my Dad purchased a Belarus 825 when we took over the grandparents farm around 1990. He really liked that tractor. Later he traded it in for a Belarus 8470?(something like that) but had a lot of issues. Mostly with the brakes sticking but also the steering was horrible. He hated it.

We also have several john deere, IHC, etc for haying and are new loader/ yard tractor is a CAT Challenger.

We stopped using the Belarus several years ago except for snow blowing but this year stopped using it and sold it privately for about $15,000.

I myself work full time, live about 30 minutes from the family farm on a rented acreage. Its in a valley along a lake with a long lane so the snow can get deep. Thus the search for a tractor. The yard is completely fenced off with 5 stand electric and I have sheep to keep the grass down so I didn't need a big mower, but have a smaller JD ride on. I looked at several kubotas that would be big enough to handle a bale but being young and not wanting to spend a lot kept searching.

Luckily I was watching all sites and came across a Belarus 820 not too far away with 2700 hrs on it, a nice LEON loader with bucket. Even with my Dads hatred for the new Belarus he said that would be a great tractor. It is very very rough cosmetically, had a few leaks, etc. but he wanted $5000 for it. I drove it around and it felt solid, steered really nice, and just felt nice. I ended up getting it for $4500. And a month later picked up a Inland (red) double auger snow blower from who else but a big new John Deere dealership that had it sitting out infront, it looked really misplaced and was definitely tossed in for likely free with a trade, and with a little talking of how bad it looked was able to get it for $300. I ended up modifying a spare set of bale forks from the farm for free. And I also picked up a 3pt link for $40 that I welded onto a length of diamond harrows (3 wide) I cut off from the farm that I used to rake the lawn/ lane with, and also used to rake up loose hay (yes I cut loose hay by hand for awhile and then would rake it with the diamond harrows, toss it on a plywood bucket that fit on the forks, and then dump into a pile in the shed). I just grab bales from the farm now.

So yeah that's my setup. Besides the pto issue I barely use the tractor and thus has been great. I have replaced a couple hydro lines and wired in some lights to the back for blowing snow in the dark otherwise.

The local dealer stopped selling Belarus a few years ago but there are quite a few in the area.

3
Maintenance - Service & Repair / Re: PTO slipping, replacing pto band?
« on: November 27, 2017, 12:14:36 PM »
Thanks Haymaker,

Do you have a picture of where the dipstick and fill plug is?

Yes it is just wider than the wheel base, its an older blower and the fan is beat up so it doesn't throw that great compared to a new one. I was going to remove it and reweld L brackets to each of the three fan wings but I ended up just drilling a couple holes and bolting some heavy belting to each one so it rubs against the outer circle. It helped a lot. I also disconnected the top auger. I'm thinking of bolting a metal plate across the top half of the fan/ between the top auger so the snow is forced more to go up and out the spout. I also gotta put some smaller shear bolts in there, it has a 3/4 bolt.

4
Maintenance - Service & Repair / Re: PTO slipping, replacing pto band?
« on: November 20, 2017, 11:01:24 AM »
I was looking into purchasing the pto bands from BelarusTractorStore.com, they were significantly cheaper than any other I saw, although located in the states. Wondering any feedback on them. I ofcourse didn't need to purchase them in the end, but if it happens again would likely just replace since I can get at the plate now much easier to loosen off the screws, and remove the pto.

5
Maintenance - Service & Repair / Re: PTO slipping, replacing pto band?
« on: November 20, 2017, 10:46:22 AM »
Got it fixed.

It isn't a big job if you don't need to take off the 3pt, but as I mentioned earlier, there's a rod covering the bolt closest to the back. So there was a lot of cotter pins to remove which were in difficult places to get at.

But in the end I got the 3pt off. The plate off, gave the farthest screw 2 full turns, and back screw a half turn. Locking the lever in the neautral position, adjusting, and then unlocking, and checking the tension on lever. My oil was also very low, I ended up putting a full 20l pail in there, and still not sure where a dipstick or fill cap would be located otherwise.

We don't have too much snow, maybe 8 inches at most but had no trouble throwing that aside.

If your pto is slipping I highly recommend this fix.

I also ended up removing that rod that was in the way so I don't need to take the 3pt off next time.

6
Maintenance - Service & Repair / Re: PTO slipping, replacing pto band?
« on: November 16, 2017, 05:24:17 PM »
Watched some of his videos.

Looks like it isn't too hard to take off the 3pt, just thinking once I go through all that work I might aswell replace the bands. With it dipping down to -20C it sure would be nice to have my truck inside the garage. I also just harvested a buck and the tractor is gunna be in the way to butcher it. I have a half hour to fiddle with it tonight to see how hard it is to take off the 3pt so will go from there. Even if I order now, will be a few weeks till parts come in anyway so might aswell see what I can or cant loosen off. I see a lot of WD-40 in its future.

Does anyone have any experience with this?

7
Maintenance - Service & Repair / Re: PTO slipping, replacing pto band?
« on: November 16, 2017, 03:32:17 PM »
Thanks for the info.

Unfortunetely the plate that covers the adjusting rods has a rod right over one of the bolts so I can't get at it.

Plus there's no way to get at it from the fron or side directly. Very frustrating. I thought it was 11/16 wrench so I heated it in my forge and gave it a bend so I could get at it at an angle but it doesn't fit, looks like its a 17mm. Will see if I can find one and then bend it into that shape, but its looking more like I'm going to take the angle grinder to the rods above and cut it out to get at it. Then reweld the rods.

8
Maintenance - Service & Repair / Re: PTO slipping, replacing pto band?
« on: November 14, 2017, 04:17:53 PM »
Update. I found this information on how to adjust the pto "brakes" or bands here.

http://www.wham.org/Belarus/PTO%20Adjustment/index.html

And I also found and read through a manual, it had another option to just adjust a "eccentric axle" at the back of the tractor but it didn't have a good diagram on how to do this.

I also found a couple places online that sell the "brakes" or bands which will be about $200, but worth it if it is fixed. I plan to try tighten up the bands as shown in the link, basically taking off the top plate and then tightening them a half turn clockwise.

If anyone has info on this before I tackle this would still be helpful, and I still don't know where to check or fill with oil.

9
Maintenance - Service & Repair / PTO slipping, replacing pto band?
« on: November 14, 2017, 11:42:28 AM »
Hello,

I own a Belarus 820.

I am young and not very mechanical but will tackle any job.

Living in Canada I have a snowblower hooked up to it, and it worked great the first year I used it (about 5 years ago). Its a big snowblower, width of tractor and double auger, and I could clear snow up to the height of the blower easily without ever needing to stop. However a couple years ago I was going a bit too hard with it, plugged up the blower, and the pto stopped spinning. I shut the pto off. Got out, cleared the snow, then kept going, but then as soon as the snow was deep it would do it again. Luckily we didn't get much snow that year and last year I just used the bucket, but it would be nice to get this fixed. I used it last week and we only had a few inches of snow but I had to continually ride the clutch or it would stop spinning.

I'm looking for information/ videos on how to fix this. I was told my oil might be low in the pto. I was told I can possibly tighten up the band?. and lastly was told to put a new pto band in it?

So my questions are 1)where is the cap to fill the pto oil? 2) info or video on how to tighten band? 3) info or video on replacing band?

Again I'm not very mechanical but I have decent tools (a heated garage) and talking with friends and family should be able to tackle this.

Thanks in advance for any suggestions.

Pages: [1]